ОГЭ по информатике · задание 11

Поиск в текстах каталога «Проза»

Дан каталог с текстами рассказов. Нужно с помощью поиска найти в них нужный факт: фамилию персонажа, название, число. На экзамене — произведения русской классики; здесь — тренировочные тексты, устроенные так же.

Где искать

  • Поиск по содержимому файлов в проводнике или в файловом менеджере.
  • Открыть файлы в текстовом редакторе или браузере и искать Ctrl+F.
  • Архив к заданию: Oge11_Proza.zip.

Как искать

  1. Выбрать редкое слово из вопроса: имя, кличку, название.
  2. Искать по корню: «Мавр», а не «Мавра» — в тексте может быть «Мавру».
  3. Прочитать предложение целиком и найти ответ рядом.

Типичные ошибки

  • Искать слово целиком в именительном падеже и ничего не найти.
  • Записать ответ не в той форме, которую просят (например, не в именительном падеже).

Разобранные варианты

Скачайте архив один раз — он общий для всех вариантов. Сначала найдите ответ сами, потом откройте разбор.

Вариант 1

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), у одного из персонажей есть служанка по имени Аграфена, которую он называет «разбойницей». Выясните фамилию этого персонажа.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Аграфен».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 01_Тихая_пристань.txt:

Фёдор Фомич Кречетов частенько бранил свою служанку Аграфену, называя её разбойницей.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Кречетов

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Аграфен'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 2

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), одного из персонажей вывезла из метели лошадь по кличке Звёздочка. Выясните фамилию этого персонажа.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Звёздочка».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 02_Осенние_письма.txt:

Если бы не верная кобыла Звёздочка, Тимофей Ильич Сыромятов так и замёрз бы в ту метель в поле.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Сыромятов

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Звёздочка'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 3

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), упоминается трактир «Три пескаря». На какой улице он стоял? В ответе запишите название улицы одним словом в именительном падеже (например, Садовая).

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Три пескаря».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 07_Уездная_история.txt:

Трактир «Три пескаря» стоял на Рыбацкой улице, у самого спуска к реке.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Рыбацкая

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Три пескаря'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 4

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), сколько яблонь росло в саду у помещика Шишкина? В ответе запишите только число.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «помещика Шишкина».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 11_Ночной_гость.txt:

В саду у помещика Шишкина росло ровно семь яблонь, и каждую он знал по имени.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: 7

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'помещика Шишкина'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 5

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), из какого города родом штабс-капитан Самохвалов? В ответе запишите название города.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «капитан Самохвалов».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 12_Полая_вода.htm:

Штабс-капитан Самохвалов был родом из уездного города Кашин и очень гордился этим.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Кашин

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'капитан Самохвалов'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 6

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), каким псевдонимом было подписано письмо, которое получил Николай Кузьмич Щеглов? В ответе запишите псевдоним без кавычек.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Щеглов».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 05_Мельница.txt:

Письмо, которое получил Николай Кузьмич Щеглов, было подписано странным псевдонимом «Отшельник».

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Отшельник

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Щеглов'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 7

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), у одного из персонажей есть пёс по кличке Разгуляй. Выясните фамилию хозяина пса.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Разгуляй».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 03_Дорога_на_ярмарку.htm:

Во дворе у Афанасия Ильича Мухина на цепи сидел лохматый пёс Разгуляй, которого боялась вся улица.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Мухин

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Разгуляй'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 8

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), в каком году на берегу реки Шексна построили водяную мельницу? В ответе запишите только число.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Шексны».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 08_Перед_грозой.txt:

Водяную мельницу на берегу реки Шексны построили ещё в 1828 году, и с тех пор она ни разу не останавливалась.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: 1828

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Шексны'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 9

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), у одного из персонажей есть пёс по кличке Барбос. Выясните фамилию хозяина пса.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Барбос».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 07_Уездная_история.txt:

Во дворе у Алексея Лукича Брусницына на цепи сидел лохматый пёс Барбос, которого боялась вся улица.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: Брусницын

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Барбос'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Вариант 10

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), в каком году на берегу реки Молога построили водяную мельницу? В ответе запишите только число.

Разбор

Шаг 1. Выбираем слово для поиска. Ищем по корню, без окончания, чтобы найти все формы слова: «Мологи».

Шаг 2. Ищем во всех файлах каталога — поиском в проводнике по содержимому файлов, в текстовом редакторе (Ctrl+F) или программой. Нашлось одно место, файл 01_Тихая_пристань.txt:

Водяную мельницу на берегу реки Мологи построили ещё в 1869 году, и с тех пор она ни разу не останавливалась.

Шаг 3. Читаем найденное предложение и выписываем ответ.

Ответ: 1869

Поиск на Python. Распакуйте архив и запустите программу рядом с папкой «Проза».

import os

key = 'Мологи'
for name in os.listdir('Проза'):
    text = open(os.path.join('Проза', name), encoding='utf-8').read()
    for sentence in text.replace('\n', ' ').split('.'):
        if key in sentence:
            print(name, ':', sentence.strip())

Для самостоятельного решения

Варианты 11–15 без разборов. Ответ можно проверить кнопкой.

Вариант 11

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), одного из персонажей вывезла из метели лошадь по кличке Метелица. Выясните фамилию этого персонажа.

Вариант 12

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), у одного из персонажей есть служанка по имени Евдокия, которую он называет «трещоткой». Выясните фамилию этого персонажа.

Вариант 13

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), у одного из персонажей есть служанка по имени Мавра, которую он называет «растеряшей». Выясните фамилию этого персонажа.

Вариант 14

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), упоминается трактир «Старая подкова». На какой улице он стоял? В ответе запишите название улицы одним словом в именительном падеже (например, Садовая).

Вариант 15

поиск в текстах

В одном из рассказов, тексты которых приведены в каталоге Проза (скачать архив), из какого города родом штабс-капитан Ветлугин? В ответе запишите название города.