ЕГЭ по информатике · задание 10

Поиск в тексте: сочетание букв и слово

Нужно посчитать, сколько раз в тексте указанных глав встречается слово или сочетание букв — отдельно или в составе других слов. К каждому варианту — файл с повестью в формате .docx.

Инструменты редактора

  • Ctrl+F — быстрый поиск, Ctrl+H — расширенный поиск с параметрами.
  • «Учитывать регистр» — различать «рук» и «Рук».
  • «Только слово целиком» — найти слово, но не части других слов.

Как решать

  1. Скопировать нужные главы в отдельный документ.
  2. Посчитать все вхождения с учётом регистра для каждого варианта написания.
  3. Посчитать отдельные слова и, если нужно, вычесть.

Типичные ошибки

  • Искать по всему файлу, а не по указанным главам.
  • Забыть слова с прописной буквы в начале предложения.
  • Не вычесть отдельные слова, когда спрашивают «в составе других слов».

Разобранные варианты

Сначала реши сам в текстовом редакторе, потом открой разбор.

Вариант 1

«рук» · сочетание в составе слов

В файле приведена повесть «Тихая пристань». С помощью текстового редактора определите, сколько раз встречается сочетание букв «рук» или «Рук» в составе других слов, но не как отдельное слово, в тексте всей повести (во всех главах). В ответе укажите только число.

Файл к варианту: Ege10_v1.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст всех глав в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «рук» со строчной буквы — 123 раза, «Рук» — 42 раза; отдельным словом («рук» или «Рук») — 54 раза.

В составе других слов: 123 + 42 − 54 = 111.

Слова, в которых встречается сочетание: Рук, Рукав, Руки, Рукопись, Рукоять, рук, рукава, рукавицы, руки, рукой, руку.

Ответ: 111

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v1.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 1 <= chapter <= 11:
        text += p + '\n'

all_ = len(re.findall(r'рук|Рук', text))               # все вхождения сочетания
alone = len(re.findall(r'\b(?:рук|Рук)\b', text))     # отдельным словом
print(all_ - alone)

Вариант 2

«дом» · отдельное слово

В файле приведена повесть «Осенние письма». С помощью текстового редактора определите, сколько раз встречается слово «дом» со строчной или прописной буквы (как отдельное слово, без учёта слов, в состав которых оно входит) в тексте глав с VIII по XI включительно. В ответе укажите только число.

Файл к варианту: Ege10_v2.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав с VIII по XI включительно в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «дом» со строчной буквы — 44 раза, «Дом» — 17 раз; отдельным словом («дом» или «Дом») — 22 раза.

Нужны только отдельные слова: 22.

Слова, в которых встречается сочетание: Бездомный, Дом, Дома, Домовой, дом, дома, домик, домой, дому.

Ответ: 22

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v2.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 8 <= chapter <= 11:
        text += p + '\n'

print(len(re.findall(r'\b(?:дом|Дом)\b', text)))

Вариант 3

«лес» · все вхождения

В файле приведена повесть «Дорога на ярмарку». С помощью текстового редактора определите, сколько раз встречается сочетание букв «лес» со строчной буквы — и как отдельное слово, и в составе других слов — в тексте глав V и VI. В ответе укажите только число.

Файл к варианту: Ege10_v3.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав V и VI в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «лес» со строчной буквы — 19 раз, «Лес» — 12 раз; отдельным словом («лес» или «Лес») — 14 раз.

Нужны все вхождения со строчной буквы: 19.

Слова, в которых встречается сочетание: Лес, Лесная, Лесник, лес, лесом, лестнице, лестницы, перелеском.

Ответ: 19

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v3.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 5 <= chapter <= 6:
        text += p + '\n'

print(text.count('лес'))

Вариант 4

«сад» · сочетание в составе слов

В файле приведена повесть «Перед грозой». С помощью текстового редактора определите, сколько раз встречается сочетание букв «сад» или «Сад» в составе других слов, но не как отдельное слово, в тексте глав III и IV. В ответе укажите только число.

Файл к варианту: Ege10_v4.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав III и IV в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «сад» со строчной буквы — 14 раз, «Сад» — 9 раз; отдельным словом («сад» или «Сад») — 10 раз.

В составе других слов: 14 + 9 − 10 = 13.

Слова, в которых встречается сочетание: Посадка, Сад, Садик, Садовник, сад, саду, усадьбе.

Ответ: 13

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v4.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 3 <= chapter <= 4:
        text += p + '\n'

all_ = len(re.findall(r'сад|Сад', text))               # все вхождения сочетания
alone = len(re.findall(r'\b(?:сад|Сад)\b', text))     # отдельным словом
print(all_ - alone)

Вариант 5

«час» · отдельное слово

В файле приведена повесть «Уездная история». С помощью текстового редактора определите, сколько раз встречается слово «час» со строчной или прописной буквы (как отдельное слово, без учёта слов, в состав которых оно входит) в тексте глав VII и VIII. В ответе укажите только число.

Файл к варианту: Ege10_v5.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав VII и VIII в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «час» со строчной буквы — 13 раз, «Час» — 11 раз; отдельным словом («час» или «Час») — 10 раз.

Нужны только отдельные слова: 10.

Слова, в которых встречается сочетание: Счастье, Час, Часовой, Часы, отчасти, участок, час.

Ответ: 10

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v5.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 7 <= chapter <= 8:
        text += p + '\n'

print(len(re.findall(r'\b(?:час|Час)\b', text)))

Вариант 6

«год» · сочетание в составе слов

В файле приведена повесть «Полая вода». С помощью текстового редактора определите, сколько раз встречается сочетание букв «год» или «Год» в составе других слов, но не как отдельное слово, в тексте глав с VIII по XI включительно. В ответе укажите только число.

Файл к варианту: Ege10_v6.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав с VIII по XI включительно в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «год» со строчной буквы — 34 раза, «Год» — 15 раз; отдельным словом («год» или «Год») — 23 раза.

В составе других слов: 34 + 15 − 23 = 26.

Слова, в которых встречается сочетание: Выгода, Год, Годовой, Годы, Погода, год, года, погоды, пригодился, угодно.

Ответ: 26

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v6.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 8 <= chapter <= 11:
        text += p + '\n'

all_ = len(re.findall(r'год|Год', text))               # все вхождения сочетания
alone = len(re.findall(r'\b(?:год|Год)\b', text))     # отдельным словом
print(all_ - alone)

Вариант 7

«мир» · все вхождения

В файле приведена повесть «Ночной гость». С помощью текстового редактора определите, сколько раз встречается сочетание букв «мир» со строчной буквы — и как отдельное слово, и в составе других слов — в тексте всей повести (во всех главах). В ответе укажите только число.

Файл к варианту: Ege10_v7.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст всех глав в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «мир» со строчной буквы — 64 раза, «Мир» — 83 раза; отдельным словом («мир» или «Мир») — 41 раз.

Нужны все вхождения со строчной буквы: 64.

Слова, в которых встречается сочетание: Мир, Мирная, Мирный, Мировой, Миром, Примирение, мир, мирно, смирилась, смирно.

Ответ: 64

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v7.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 1 <= chapter <= 10:
        text += p + '\n'

print(text.count('мир'))

Вариант 8

«вод» · сочетание в составе слов

В файле приведена повесть «Соседи». С помощью текстового редактора определите, сколько раз встречается сочетание букв «вод» или «Вод» в составе других слов, но не как отдельное слово, в тексте глав I, II и III. В ответе укажите только число.

Файл к варианту: Ege10_v8.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав I, II и III в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «вод» со строчной буквы — 32 раза, «Вод» — 12 раз; отдельным словом («вод» или «Вод») — 20 раз.

В составе других слов: 32 + 12 − 20 = 24.

Слова, в которых встречается сочетание: Вод, Вода, Водопад, Водяная, Завод, Наводнение, Проводник, вод, водой, воды, доводить.

Ответ: 24

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v8.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 1 <= chapter <= 3:
        text += p + '\n'

all_ = len(re.findall(r'вод|Вод', text))               # все вхождения сочетания
alone = len(re.findall(r'\b(?:вод|Вод)\b', text))     # отдельным словом
print(all_ - alone)

Вариант 9

«рук» · отдельное слово

В файле приведена повесть «Зимний вечер». С помощью текстового редактора определите, сколько раз встречается слово «рук» со строчной или прописной буквы (как отдельное слово, без учёта слов, в состав которых оно входит) в тексте глав с I по IV включительно. В ответе укажите только число.

Файл к варианту: Ege10_v9.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав с I по IV включительно в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «рук» со строчной буквы — 41 раз, «Рук» — 16 раз; отдельным словом («рук» или «Рук») — 20 раз.

Нужны только отдельные слова: 20.

Слова, в которых встречается сочетание: Рук, Рукав, Руки, Рукопись, Рукоять, рук, рукава, рукавицы, руки, рукой, руку.

Ответ: 20

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v9.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 1 <= chapter <= 4:
        text += p + '\n'

print(len(re.findall(r'\b(?:рук|Рук)\b', text)))

Вариант 10

«дом» · сочетание в составе слов

В файле приведена повесть «Старая мельница». С помощью текстового редактора определите, сколько раз встречается сочетание букв «дом» или «Дом» в составе других слов, но не как отдельное слово, в тексте глав II и III. В ответе укажите только число.

Файл к варианту: Ege10_v10.docx (Word; открывается и в LibreOffice Writer).

Разбор

Шаг 1. Оставляем только нужные главы. Удобно скопировать текст глав II и III в новый документ, чтобы поиск не задел остальные главы.

Шаг 2. Поиск с параметрами. В окне «Найти и заменить» (Ctrl+H) включаем «Учитывать регистр», вводим сочетание и смотрим количество найденных. Флажок «Только слово целиком» оставляет только отдельные слова.

Шаг 3. Считаем. В этих главах «дом» со строчной буквы — 24 раза, «Дом» — 13 раз; отдельным словом («дом» или «Дом») — 11 раз.

В составе других слов: 24 + 13 − 11 = 26.

Слова, в которых встречается сочетание: Бездомный, Дом, Дома, Домашние, Домовой, дом, дома, домик, домой, дому, мёдом.

Ответ: 26

Проверка на Python. Положите файл варианта рядом с программой. Сторонние библиотеки не нужны: документ .docx — это zip-архив с текстом в XML.

import re
import zipfile
from html import unescape

# .docx — это zip-архив, текст лежит в word/document.xml: абзацы <w:p>, куски текста <w:t>
xml = zipfile.ZipFile('Ege10_v10.docx').read('word/document.xml').decode('utf-8')
paras = [unescape(''.join(re.findall(r'<w:t[^>]*>(.*?)</w:t>', p))) for p in re.findall(r'<w:p>.*?</w:p>', xml)]

ROMAN = ['I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'XIII', 'XIV', 'XV']
chapter = 0
text = ''
for p in paras:
    if p.startswith('Глава '):
        chapter = ROMAN.index(p.split()[1]) + 1
    elif 2 <= chapter <= 3:
        text += p + '\n'

all_ = len(re.findall(r'дом|Дом', text))               # все вхождения сочетания
alone = len(re.findall(r'\b(?:дом|Дом)\b', text))     # отдельным словом
print(all_ - alone)

Для самостоятельного решения

Варианты 11–15 без разборов. Ответ можно проверить кнопкой.

Вариант 11

«час» · сочетание в составе слов

В файле приведена повесть «На постоялом дворе». С помощью текстового редактора определите, сколько раз встречается сочетание букв «час» или «Час» в составе других слов, но не как отдельное слово, в тексте глав I, II и III. В ответе укажите только число.

Файл к варианту: Ege10_v11.docx (Word; открывается и в LibreOffice Writer).

Вариант 12

«лес» · отдельное слово

В файле приведена повесть «Последнее лето». С помощью текстового редактора определите, сколько раз встречается слово «лес» со строчной или прописной буквы (как отдельное слово, без учёта слов, в состав которых оно входит) в тексте всей повести (во всех главах). В ответе укажите только число.

Файл к варианту: Ege10_v12.docx (Word; открывается и в LibreOffice Writer).

Вариант 13

«сад» · все вхождения

В файле приведена повесть «Белые ночи». С помощью текстового редактора определите, сколько раз встречается сочетание букв «сад» со строчной буквы — и как отдельное слово, и в составе других слов — в тексте глав VI и VII. В ответе укажите только число.

Файл к варианту: Ege10_v13.docx (Word; открывается и в LibreOffice Writer).

Вариант 14

«мир» · сочетание в составе слов

В файле приведена повесть «Летние сумерки». С помощью текстового редактора определите, сколько раз встречается сочетание букв «мир» или «Мир» в составе других слов, но не как отдельное слово, в тексте глав III, IV и V. В ответе укажите только число.

Файл к варианту: Ege10_v14.docx (Word; открывается и в LibreOffice Writer).

Вариант 15

«год» · отдельное слово

В файле приведена повесть «Рябиновый край». С помощью текстового редактора определите, сколько раз встречается слово «год» со строчной или прописной буквы (как отдельное слово, без учёта слов, в состав которых оно входит) в тексте глав II и III. В ответе укажите только число.

Файл к варианту: Ege10_v15.docx (Word; открывается и в LibreOffice Writer).